centos7 编译安装 php7.3.11

2019-11-21 来源: GuangJunGao 发布在  https://www.cnblogs.com/gaoguangjun/p/11904698.html

1.安装依赖

yum install -y libxml2 *openssl* libcurl* libjpeg* libpng* freetype* libmcrypt* gcc gcc-c++

2.安装php
  2.1)解决依赖+1

  因为测试发现的一个问题,php安装依赖 libzip(需安装1.5.1的版本),然后蛋疼的事情发生了,libzip1.5.1版本需要cmake3.0.2以上版本

  接下来先解决cmake的版本(我直接使用的cmake3.6.2,这肯定是满足需求了吧):
  安装包:

wget https://cmake.org/files/v3.6/cmake-3.6.2.tar.gz

  安装:

 #编译
 ./
 #安装
 ./bootstrap
 gmake
 gmake install
 #测试版本
 /usr/local/bin/cmake --version
 #查看系统rpm的cmake包
 rpm -qa |grep cmake
 #卸载系统的cmake
 yum remove cmake -y
 #软链接并进行测试版本
 ln -s /usr/local/bin/cmake /usr/bin/
 cmake --version

  2.2)解决依赖+2

  php安装依赖 libzip1.5.1\

#如果系统有低版本的libzip需先卸载
rpm -qa| grep libzip
yum remove libzip*

# 源码编译安装 libzip 最新版
# libzip 官网地址:https://libzip.org
wget https://nih.at/libzip/libzip-1.5.1.tar.gz
.tar.gz
cd libzip-
## 查看 INSTALL.md 其中有安装提示
mkdir build
cd build
cmake ..
make
make test
make install

重头戏php编译安装

php官方安装包和文档:

http://www.linuxfromscratch.org/blfs/view/svn/general/php.html

先去官方下载安装包!!!

开始解压编译安装

 #解压
 xz -d php-.tar.xz
 .tar
 cd php-

 #安装(也可以根据官方)
 ./configure --prefix=/usr/local/php --with-mysqli --with-iconv-dir --with-freetype-dir --with-jpeg-dir --with-png-dir --with-zlib --with-libxml-dir --enable-simplexml --enable-xml --disable-rpath --enable-bcmath --enable-soap --enable-zip --with-curl --enable-fpm --with-fpm-user=www --with-fpm-group=www --enable-mbstring --enable-sockets --with-gd --with-openssl --with-mhash --enable-opcache --disable-fileinfo

 make
 make install

配置

 #主要是解决测试启动配置文件
 cp /usr/local/php/etc/php-fpm.conf.default /usr/local/php/etc/php-fpm.conf
 cp /usr/local/php/etc/php-fpm.d/www.conf.default /usr/local/php/etc/php-fpm.d/www.conf

 #启动试试能不能启动
 /usr/local/php/sbin/php-fpm

命令行下运行php,需要将可执行文件复制到环境变量

cp /usr/local/php/bin/php /usr/local/bin/php

# 命令行下查看 php 版本
php -v

相关文章