在CentOS上安装第三方软件库EPEL

2016-10-03 来源: lanfeng2291564 发布在  http://www.cnblogs.com/fenglan/p/5929259.html

Extra Packages for Enterprise Linux (EPEL)【企业版 Linux 附加软件包(以下简称 EPEL)】是一个由特别兴趣小组创建、维护并管理的,针对 红帽企业版 Linux(RHEL)及其衍生发行版(比如 CentOS、 Scientific Linux)的一个高质量附加软件包项目。
EPEL 的软件包通常不会与企业版Linux官方源中的软件包发生冲突,或者互相替换文件。EPEL与Fedora项目基本一致,包含完整的构建系统、升级管理器、镜像管理器等等。

EPEL
包含一个叫做epel-release的包,这个包包含了EPEL源的gpg密钥和软件源信息。您可以通过yum安装到您的企业版Linux发行版上。除了epel-release源,还有一个叫做epel-testing的源,这个源包含最新的测试软件包,其版本很新但是安装有风险,请自行斟酌。

注意: 有些第三方软件源需要 EPEL 的'epel-testing'源来安装依赖组件,请务必在系统设置中启用本源。 这里 有相关的开启教程。(相关配置文件位于:/etc/yum.repos.d/epel-testing.repo)。



1.首先检查系统是否安装epel-release

  1. [root@localhost ~]
  2. # rpm -q epel-release
  3. package epel-release is not installed

2.安装EPEL

  1. [root@localhost ~]# rpm -ivh http://mirrors.ustc.edu.cn/fedora/epel/6/x86_64/epel-release-6-8.noarch.rpm
  2. Retrieving http://mirrors.ustc.edu.cn/fedora/epel/6/x86_64/epel-release-6-8.noarch.rpm
  3. Preparing...                ########################################### [100%]
  4. 1:epel-release           ########################################### [100%]

注意:

1、要安装最新版本的EPEL,请前往 http://mirrors.ustc.edu.cn/fedora/epel/ 中查找最新版本的URL地址,这里采用的是6.8版本

32位:http://mirrors.ustc.edu.cn/fedora/epel/6/i386/epel-release-6-8.noarch.rpm

64位:http://mirrors.ustc.edu.cn/fedora/epel/6/x86_64/epel-release-6-8.noarch.rpm



2、若出现下面类似错误,则表示对应的URL已经不存在,需要重新找EPEL的版本,请前往 http://mirrors.ustc.edu.cn/fedora/epel/ 获取需要的版本

  1. [root@localhost ~]# rpm -ivh http://mirrors.ustc.edu.cn/fedora/epel/6/x86_64/epel-release-6-8.noarch.rpm
  2. Retrieving http://mirrors.ustc.edu.cn/fedora/epel/6/x86_64/epel-release-6-8.noarch.rpm
  3. curl: (22) The requested URL returned error: 404 Not Found
  4. error: skipping http://mirrors.ustc.edu.cn/fedora/epel/6/x86_64/epel-release-6-8.noarch.rpm - transfer failed

#2.1 安装成功

  1. [root@localhost ~]# rpm -q epel-release
  2. epel-release-6-8.noarch

#2.2 查看其所依附的软件文件

  1. [root@localhost ~]# rpm -qR epel-release
  2. /bin/sh
  3. /bin/sh
  4. config(epel-release) = 6-8
  5. redhat-release >= 6
  6. rpmlib(CompressedFileNames) <= 3.0.4-1
  7. rpmlib(FileDigests) <= 4.6.0-1
  8. rpmlib(PayloadFilesHavePrefix) <= 4.0-1
  9. rpmlib(PayloadIsXz) <= 5.2-1

#2.3 卸载

  1. [root@localhost ~]# rpm -e epel-release
  2. warning: /etc/yum.repos.d/epel.repo saved as /etc/yum.repos.d/epel.repo.rpmsave

#2.4 设置源级别

  1. [root@localhost ~]# vi /etc/yum.repos.d/epel.repo
  2. 设置 /etc/yum.repos.d/epel.repo 中源的级别为 priority=11

#2.5 搜索软件包

若要查看 EPEL Repo 中是否存在某个软件包:yum search package-name,若搜索git

  1. [root@localhost ~]# yum search git
  2. Loaded plugins: fastestmirror, refresh-packagekit, security
  3. Loading mirror speeds from cached hostfile
  4. * base: mirrors.aliyun.com
  5. * epel: mirrors.hust.edu.cn
  6. * extras: mirrors.aliyun.com
  7. * updates: mirror.bit.edu.cn
  8. ============================== N/S Matched: git ===============================
  9. nodejs-github-url-from-git.noarch : Parse a GitHub git URL and return the GitHub repository URL
  10. php-phpunit-git.noarch : Simple wrapper for Git
  11. trac-git-plugin.noarch : GIT version control plugin for Trac
  12. GitPython.noarch : Python Git Library
  13. cgit.x86_64 : A fast web interface for git
  14. git-annex.x86_64 : Manage files with git, without checking their contents into git
  15. git-ftp.noarch : Git powered FTP client written as shell script
  16. git-gui.noarch : Git GUI tool
  17. git-review.noarch : A git helper for integration with Gerrit
  18. git2cl.noarch : Converts git logs to GNU style ChangeLog format
  19. gitolite.noarch : Highly flexible server for git directory version tracker
  20. gitosis.noarch : Git repository hosting application
  21. gitstats.noarch : Generates statistics based on GIT repository activity
  22. // ……(略)
  23. tkgate-fr.x86_64 : Locales and examples for tkgate, Digital Circuit Simulator
  24. tkgate-it.x86_64 : Locales and examples for tkgate, Digital Circuit Simulator
  25. tkgate-ja.x86_64 : Locales and examples for tkgate, Digital Circuit Simulator
  26. tuxpaint.x86_64 : Drawing program designed for young children
  27. xmlsec1-devel.i686 : Libraries, includes, etc. to develop applications with XML Digital
  28. : Signatures and XML Encryption support.
  29. xmlsec1-devel.x86_64 : Libraries, includes, etc. to develop applications with XML Digital
  30. : Signatures and XML Encryption support.
  31. Name and summary matches only, use "search all" for everything.

3. 安装第三方软件

使用yum install package-name命令安装第三方软件,如使用yum install git安装git

    1. [root@localhost ~]# yum install git
    2. Loaded plugins: fastestmirror, refresh-packagekit, security
    3. Loading mirror speeds from cached hostfile
    4. epel/metalink                                                 | 5.5 kB     00:00
    5. * base: mirrors.aliyun.com
    6. * epel: ftp.sjtu.edu.cn
    7. * extras: mirrors.aliyun.com
    8. * updates: mirror.bit.edu.cn
    9. epel                                                          | 4.4 kB     00:00
    10. epel/primary_db                                               | 6.0 MB     01:19
    11. Setting up Install Process
    12. Resolving Dependencies
    13. --> Running transaction check
    14. ---> Package git.x86_64 0:1.7.1-3.el6_4.1 will be installed
    15. --> Processing Dependency: perl-Git = 1.7.1-3.el6_4.1 for package: git-1.7.1-3.el6_4.1.x86_64
    16. --> Processing Dependency: perl(Git) for package: git-1.7.1-3.el6_4.1.x86_64
    17. --> Processing Dependency: perl(Error) for package: git-1.7.1-3.el6_4.1.x86_64
    18. --> Running transaction check
    19. ---> Package perl-Error.noarch 1:0.17015-4.el6 will be installed
    20. ---> Package perl-Git.noarch 0:1.7.1-3.el6_4.1 will be installed
    21. --> Finished Dependency Resolution
    22. Dependencies Resolved
    23. ==================================================================================
    24. Package                Arch       Version                 Repository        Size
    25. ==================================================================================
    26. Installing:
    27. git                    x86_64     1.7.1-3.el6_4.1         base             4.6 M
    28. Installing for dependencies:
    29. perl-Error             noarch     1:0.17015-4.el6         base              29 k
    30. perl-Git               noarch     1.7.1-3.el6_4.1         base              28 k
    31. Transaction Summary
    32. ==================================================================================
    33. Install       3 Package(s)
    34. Total download size: 4.7 M
    35. Installed size: 15 M
    36. Is this ok [y/N]: y
    37. Downloading Packages:
    38. (1/3): git-1.7.1-3.el6_4.1.x86_64.rpm                         | 4.6 MB     00:33
    39. (2/3): perl-Error-0.17015-4.el6.noarch.rpm                    |  29 kB     00:00
    40. (3/3): perl-Git-1.7.1-3.el6_4.1.noarch.rpm                    |  28 kB     00:00
    41. ----------------------------------------------------------------------------------
    42. Total                                                          140 kB/s | 4.7 MB     00:34
    43. warning: rpmts_HdrFromFdno: Header V3 RSA/SHA1 Signature, key ID c105b9de: NOKEY
    44. Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6
    45. Importing GPG key 0xC105B9DE:
    46. Userid : CentOS-6 Key (CentOS 6 Official Signing Key) <centos-6-key@centos.org>
    47. Package: centos-release-6-4.el6.centos.10.x86_64 (@anaconda-CentOS-201303020151.x86_64/6.4)
    48. From   : /etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6
    49. Is this ok [y/N]: y    (注:这里为输入的内容,导入GPG key)
    50. Running rpm_check_debug
    51. Running Transaction Test
    52. Transaction Test Succeeded
    53. Running Transaction
    54. Warning: RPMDB altered outside of yum.
    55. Installing : 1:perl-Error-0.17015-4.el6.noarch                             1/3
    56. Installing : perl-Git-1.7.1-3.el6_4.1.noarch                               2/3
    57. Installing : git-1.7.1-3.el6_4.1.x86_64                                    3/3
    58. Verifying  : git-1.7.1-3.el6_4.1.x86_64                                    1/3
    59. Verifying  : perl-Git-1.7.1-3.el6_4.1.noarch                               2/3
    60. Verifying  : 1:perl-Error-0.17015-4.el6.noarch                             3/3
    61. Installed:
    62. git.x86_64 0:1.7.1-3.el6_4.1
    63. Dependency Installed:
    64. perl-Error.noarch 1:0.17015-4.el6              perl-Git.noarch 0:1.7.1-3.el6_4.1
    65. Complete!

相关文章